• Hi guest! As you can see, the new Wizard Forums has been revived, and we are glad to have you visiting our site! However, it would be really helpful, both to you and us, if you registered on our website! Registering allows you to see all posts, and make posts yourself, which would be great if you could share your knowledge and opinions with us! You could also make posts to ask questions!

Not wanting emails constantly sent for everything...

KjEno186

Zealot
Joined
Apr 9, 2022
Messages
168
Awards
4
... and having un-checked the appropriate boxes in my preferences and "Saved," I still get emails about someone posting on threads I've posted on, among other things. I wouldn't mind occasional emails about forum announcements, but I get tired of emails being sent for every little thing.
 
Solution
Account > Preferences > Content Options
Account > Account Details > Email Options

Are all of those unchecked?

If so, that means you're getting emails from threads that you interacted with in the past, before you updated your settings... in that case, do the following:
  1. Go here: https://wizardforums.com/watched/threads
  2. Scroll to the bottom and click "Select All"
  3. In the dropdown next to it, select "Disable email notification"
  4. Press "Go"
That should disable notifications for all the threads you were "watching" before you turned off the setting in your profile.

If this still doesn't work or if you're having some issue with it, lemme know and I'll try doing it from the back end.

auza121

Neophyte
Joined
Mar 28, 2022
Messages
48
Awards
1
go to preferences on your account then click account details on the left. then uncheck the automatic email section
 

SkullTraill

Glorious Light of Knowledge and Power
Staff member
Custodian
Librarian
Joined
Apr 12, 2021
Messages
1,041
Awards
16
Account > Preferences > Content Options
Account > Account Details > Email Options

Are all of those unchecked?

If so, that means you're getting emails from threads that you interacted with in the past, before you updated your settings... in that case, do the following:
  1. Go here: https://wizardforums.com/watched/threads
  2. Scroll to the bottom and click "Select All"
  3. In the dropdown next to it, select "Disable email notification"
  4. Press "Go"
That should disable notifications for all the threads you were "watching" before you turned off the setting in your profile.

If this still doesn't work or if you're having some issue with it, lemme know and I'll try doing it from the back end.
 
Solution
Top